artnet network spam

Questions and issues concerning LXConsole (MacOS)
stanelie
Posts: 14
Joined: Fri Mar 04, 2022 5:00 pm

artnet network spam

Postby stanelie » Fri Sep 16, 2022 3:05 pm

Hello.

I am trying to not spam my whole network with broadcast artnet packets. They slow everything down. So, in the "DMX out" tab of the preferences, I've set it to send to the address of my artnet device only by setting the destination IP address under "send to address" and checking the checkbox. It works.

However, whenever I connect/disconnect wifi (to go to the internet for example), the address box resets to the broadcast address and I am then spamming my networks again.

Is there a way to make the address in the address box stick?

Thanks.

admin
Site Admin
Posts: 148
Joined: Mon Nov 20, 2017 4:31 pm

Re: artnet network spam

Postby admin » Fri Sep 16, 2022 4:52 pm

Do you have the "Set to Broadcast Address" box checked? If so, the value of the unicast address will always be set to the broadcast address on startup and when the network changes.

But, you should not need to check the "Send to Address" box unless there is some reason that Art-Net discovery is not working. You can click the "Art-Net Nodes..." button to see a list of discovered devices. LXConsole will automatically unicast the proper universe to any detected output that matches its net/subnet/universe capability. LXConsole does not send universes that are not patched.

As long as the only channels you have patched are going to local universe 11/Art-Net universe 10, and you have a device that receives that universe from the Art-Net, it should work that LXConsole only sends Art-Net packets directed to that device, not the entire network. (the "Send to Address" box is unchecked) The only exception would be if there's an issue with Art-Net discovery. In which case, if LXConsole does not find a device listening to that universe, it won't send anything. Or, there are also other devices on the network that are listening to that universe. In that case, LXConsole will also send Art-Net packets via unicast to those other devices as well.

stanelie
Posts: 14
Joined: Fri Mar 04, 2022 5:00 pm

Re: artnet network spam

Postby stanelie » Wed Sep 21, 2022 1:54 pm

Thanks for all this info!
Yes, the "set to broadcast address" checkbox was checked, so, I unchecked it. Thanks.

My artnet devices are not getting detected because they don't behave correctly, they are homemade ESP32 based devices and not all artnet behaviors have been implemented.

Thanks again!